import Foundation
let pattern = #"([a-zA-Z0-9_-]+?)_[\d\w]{8}\-(?:[\d\w]{4}\-){3}[\d\w]{12}[_\d\w\s-]*$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"/body/RenderingA_6c91dd08-c318-4aa1-9883-bd0ed8af711_UnqiueKeyA/RenderingB_1a9cbcf1-e80f-4448-a21e-12e66f38c015_UniqueKeyB/RenderingC_1a9cbcf1-e80f-4448-a21e-12e66f38c015_UniqueKeyC"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)