import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<error_date>^[\\w\\/\\.]+)\\s+(?P<error_time>[\\w\\/\\.\\:]+)\\s+\\*(?P<error_level>\\w+)\\*\\s+\\[((?P<error_ip>[\\d\\.]+)\\s+\\[(?P<error_thread_id>.+)\\]\\s+(?P<error_request_method>\\w+)\\s+(?P<error_urlpath>.+)\\s+(?P<error_req_protocol>.+)|(?P<error_thread>.+?))\\]\\s+(?P<error_message>.+[\\n]?.+)";
final String string = "\n"
+ "14.05.2021 11:52:20.598 *INFO* [oak-repository-executor-1] com.adobe.granite.repository Service [31211, [org.apache.jackrabbit.oak.api.jmx.SessionMBean]] ServiceEvent REGISTERED\n\n"
+ "14.05.2021 11:52:22.964 *WARN* [10.153.117.93 [1620993142877] GET /content/ewp-marketing-websites/legal/gl/en/c/prolaw-workspace.html HTTP/1.1] com.tr.emcm.slingmodels.EyeBrowDateModel Error while formatting date: \n"
+ "java.text.ParseException: Unparseable date: \"\"\n"
+ " at java.text.DateFormat.parse(DateFormat.java:366)\n"
+ " at com.tr.emcm.slingmodels.EyeBrowDateModel.setDate(EyeBrowDateModel.java:92)\n"
+ " at com.tr.emcm.slingmodels.EyeBrowDateModel.lambda$init$2(EyeBrowDateModel.java:72)\n"
+ "14.05.2021 11:52:22.972 *ERROR* [10.43.32.58 [1620993142925] GET /content/volvo/volvo-financial-services/markets/netherlands/nl-nl/home.html HTTP/1.1] com.volvo.platform.components.controllers.VolvoGroupStandardHeaderComponent RepositoryException Error occured while processing fetchExcelValues/content/volvo/volvo-financial-services/markets/netherlands/nl-nl/jcr:content/header\n"
+ "javax.jcr.AccessDeniedException: OakAccess0000: Access denied\n"
+ " at org.apache.jackrabbit.oak.api.CommitFailedException.asRepositoryException(CommitFailedException.java:232)\n"
+ " at org.apache.jackrabbit.oak.api.CommitFailedException.asRepositoryException(CommitFailedException.java:213)\n"
+ " at org.apache.jackrabbit.oak.jcr.delegate.SessionDelegate.newRepositoryException(SessionDelegate.java:669)\n"
+ "14.05.2021 11:52:22.980 *WARN* [10.105.105.19 [1620993142700] GET /content/onehub_nfz/de/de/angebote-und-finanzprodukte/gross-und-sonderkunden/kommunen-und-behoerden.dir.dir.dir.dir.dir.dir.dir.dir.dir.dir.dir.dir.html/__layer/layers/fahrzeugkauf/ansprechpartner-blaulichtfahrzeuge HTTP/1.1] org.apache.sling.caconfig.resource.impl.def.DefaultConfigurationResourceResolvingStrategy Ignoring reference to /conf/vwa-ngw18/settings from /conf/vwa-ngw18/settings - Probably misconfigured as it ends with '/settings'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}