package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?is)([^|&!()=<>]*)([=!<>]{1,2})([^|&!()=<>]*)(?:([|&])\(?([^|!&()=<>]*)([=!<>]{1,2})([^|&!()=<>]*)\)?)?`)
var str = `displayState=error&(state!=aborted|(state=cancelled|state=timed out))`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}