re = /([^|&!()=<>]*)([=!<>]{1,2})([^|&!()=<>]*)(?:([|&])\(?([^|!&()=<>]*)([=!<>]{1,2})([^|&!()=<>]*)\)?)?/i
str = 'displayState=error&(state!=aborted|(state=cancelled|state=timed out))'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end