$re = '/(?:^|,)?\s*(.*?)\s+((?:\d+,)?\d+)([a-z\/]*)/m';
$str = 'Vitamin A 6,000iu/kg,Vitamin D3 80iu/kg Vitamin E PLUS 240iu/kg, Potassium 32mg/kg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);