re = /(?:^|,)?\s*(.*?)\s+((?:\d+,)?\d+)([a-z\/]*)/m
str = 'Vitamin A 6,000iu/kg,Vitamin D3 80iu/kg Vitamin E PLUS 240iu/kg, Potassium 32mg/kg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end