re = /#(\d+)#\s+(\d{4}-\d{2}-\d{2})T(\d{2}:\d{2}:\d{2})-(\d{2}:\d{2})\s+(\S+)\s+(\S+)\s+(.*)\s.* action "(.+)"\s+.*\s+return\s+code\s+(\d+)\./
str = '#134# 2015-05-14T21:22:40-04:00 PRODNJ-RPT01 Microsoft-Windows-TaskScheduler Task Scheduler successfully c ompleted task "\\WarmUp Vantage" , instance "{E26D061B-15DD-4F58-B80C-4F11225333DF}" , action "D:\\warmupscr ipt\\BSAImpersonationIssueFixer.exe" with return code 0. '
# Print the match result
str.match(re) do |match|
puts match.to_s
end