// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"#(\d+)#\s+(\d{4}-\d{2}-\d{2})T(\d{2}:\d{2}:\d{2})-(\d{2}:\d{2})\s+(\S+)\s+(\S+)\s+(.*)\s.* action "(.+)"\s+.*\s+return\s+code\s+(\d+)\."#).unwrap();
let string = "#134# 2015-05-14T21:22:40-04:00 PRODNJ-RPT01 Microsoft-Windows-TaskScheduler Task Scheduler successfully c ompleted task \"\\WarmUp Vantage\" , instance \"{E26D061B-15DD-4F58-B80C-4F11225333DF}\" , action \"D:\\warmupscr ipt\\BSAImpersonationIssueFixer.exe\" with return code 0. ";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}