#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=Description Amount\n)(?:(?!\d+,\d).*\n)*"
Local $sString = "Description Amount" & @CRLF & _
"Being the Amount received from above branch in favour of SAF SAF" & @CRLF & _
"FOR THE MONTH OF JANUARY-2021." & @CRLF & _
"3,24,500.00" & @CRLF & _
"" & @CRLF & _
"Description Amount" & @CRLF & _
"Being the Amount received from above branch in favour of SD SAF" & @CRLF & _
"VALUE SAF OF CHAPAINAWABGANJ AREA FOR THE MONTH OF" & @CRLF & _
"JANUARY 2021" & @CRLF & _
"9,18,049.00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")