import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=Description Amount\\n)(?:(?!\\d+,\\d).*\\n)*";
final String string = "Description Amount\n"
+ "Being the Amount received from above branch in favour of SAF SAF\n"
+ "FOR THE MONTH OF JANUARY-2021.\n"
+ "3,24,500.00\n\n"
+ "Description Amount\n"
+ "Being the Amount received from above branch in favour of SD SAF\n"
+ "VALUE SAF OF CHAPAINAWABGANJ AREA FOR THE MONTH OF\n"
+ "JANUARY 2021\n"
+ "9,18,049.00";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}