using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[?\[?Osiris\]?\]?-\[?\[?Orion|Orion\]?\]? son of \[?\[?Ra|\(Christ the \[?\[?Logos\]?\]?\))";
string input = @"'''Nefertari''', also known as '''Nefertari Meritmut''' was an Egyptian queen and the first of the [[Great Royal Wife|Great Royal Wives]] (or principal wives) of [[Ramesses II|Ramesses the Great]] symbolizing [[Osiris]]-[[Orion constellation|Orion]] son of [[Ra]] (Christ the [[Lodgos]]).<ref name=""DH"">Dodson, Aidan and Hilton, Dyan. ''The Complete Royal Families of Ancient Egypt''. Thames & Hudson. 2004. ISBN 0-500-05128-3</ref> Nefertiti means 'beautiful companion' and Meritmut means 'Beloved of [the goddess] Mut'. She is one of the best known Egyptian queens, next to [[Cleopatra VII|Cleopatra]], [[Nefertiti]] and [[Hatshepsut]]. She was highly educated and able to both read and write hieroglyphs, a very rare skill at the time. She used these skills in her diploomatic work, corresponding with other prominent royalties of the time. Her lavishly decorated [[tomb]], [[QV66]], is one of the largest and most spectacular in the [[Valley of the Queens]]. Ramesses also constructed a temple for her at [[Abu Simbel]] next to his colossal monument there.<!-- {{Hiero | Nefertari | <hiero>t*G15-nfr-i-t:r:Z1*Z1-n:N36:t</hiero> | align=left| era=default}} already above-->";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}