# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\[?\[?Osiris\]?\]?-\[?\[?Orion|Orion\]?\]? son of \[?\[?Ra|\(Christ the \[?\[?Logos\]?\]?\))"
test_str = "'''Nefertari''', also known as '''Nefertari Meritmut''' was an Egyptian queen and the first of the [[Great Royal Wife|Great Royal Wives]] (or principal wives) of [[Ramesses II|Ramesses the Great]] symbolizing [[Osiris]]-[[Orion constellation|Orion]] son of [[Ra]] (Christ the [[Lodgos]]).<ref name=\"DH\">Dodson, Aidan and Hilton, Dyan. ''The Complete Royal Families of Ancient Egypt''. Thames & Hudson. 2004. ISBN 0-500-05128-3</ref> Nefertiti means 'beautiful companion' and Meritmut means 'Beloved of [the goddess] Mut'. She is one of the best known Egyptian queens, next to [[Cleopatra VII|Cleopatra]], [[Nefertiti]] and [[Hatshepsut]]. She was highly educated and able to both read and write hieroglyphs, a very rare skill at the time. She used these skills in her diploomatic work, corresponding with other prominent royalties of the time. Her lavishly decorated [[tomb]], [[QV66]], is one of the largest and most spectacular in the [[Valley of the Queens]]. Ramesses also constructed a temple for her at [[Abu Simbel]] next to his colossal monument there.<!-- {{Hiero | Nefertari | <hiero>t*G15-nfr-i-t:r:Z1*Z1-n:N36:t</hiero> | align=left| era=default}} already above-->"
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.