#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?))[, ].{1,}\[([0-3][0-9]\/\w{3}\/[0-9]{4}):([0-2][0-9]:[0-5][0-9]:[0-5][0-9]) ((?:\+|\-)[0-9]{4})\].{1,}"(GET|POST|HEAD|PUT|DELETE|TRACE|CONNECT) ([\/\w\.\-\?\_\=\*\$\%\:]+).{1,}" (\b\d{3}) (\d+|-) "((?:(?:http(?:s)?:\/\/.)?(www\.)?[-a-zA-Z0-9@:%._\+~#=]{2,256}\.[a-z]{2,24}\b[-a-zA-Z0-9@:%_\+.~#?&\/\/=]*)|-)" "([^"]+)" "([^"]+)"$"
Local $sString = "94.185.250.10 - - [06/Aug/2015:11:34:23 +0200] "GET / HTTP/1.1" 200 686 "-" "Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/44.0.2403.125 Safari/537.36" "username=John Doe; testCookie=testValue""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")