import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?))[, ].{1,}\\[([0-3][0-9]\\/\\w{3}\\/[0-9]{4}):([0-2][0-9]:[0-5][0-9]:[0-5][0-9]) ((?:\\+|\\-)[0-9]{4})\\].{1,}\"(GET|POST|HEAD|PUT|DELETE|TRACE|CONNECT) ([\\/\\w\\.\\-\\?\\_\\=\\*\\$\\%\\:]+).{1,}\" (\\b\\d{3}) (\\d+|-) \"((?:(?:http(?:s)?:\\/\\/.)?(www\\.)?[-a-zA-Z0-9@:%._\\+~#=]{2,256}\\.[a-z]{2,24}\\b[-a-zA-Z0-9@:%_\\+.~#?&\\/\\/=]*)|-)\" \"([^\"]+)\" \"([^\"]+)\"$";
final String string = "94.185.250.10 - - [06/Aug/2015:11:34:23 +0200] \"GET / HTTP/1.1\" 200 686 \"-\" \"Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/44.0.2403.125 Safari/537.36\" \"username=John Doe; testCookie=testValue\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}