using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<![\s\S\r])(.*)";
string substitution = @"---\ntags: \n - m/diary\n---\n\n$1";
string input = @"# project1
I could have put any other inline tag or string there.
This main body line could have been the very first line as well, if no tags exist.
Change the keys after each `\n` and add or remove any more keys you want.
In this example, I added the desired tag in the indented multi-line format favoured by Obsidian.
If it is a first time doing regex changes, make a backup of vault or Diary folder.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}