const regex = /^(?<![\s\S\r])(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<![\\s\\S\\r])(.*)', 'gm')
const str = `# project1
I could have put any other inline tag or string there.
This main body line could have been the very first line as well, if no tags exist.
Change the keys after each \`\\n\` and add or remove any more keys you want.
In this example, I added the desired tag in the indented multi-line format favoured by Obsidian.
If it is a first time doing regex changes, make a backup of vault or Diary folder.`;
const subst = `---\ntags: \n - m/diary\n---\n\n$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);