const regex = /[ ^\s]([ ]{1,})[ ^\s]/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[ ^\\s]([ ]{1,})[ ^\\s]', 'gmi')
const str = `5382948 EGELSTON^ELIZABETH 0102126763 1942-09-17 00:00:00.000 F 2003-02-09 00:00:00.000 1899-12-30 19:39:10.000 CT03011350 28465 1.2.124.113532.10.7.222.5.20030209.190851.3087742 NULL UNKNOWN^RADNET CT NULL PE CHEST 764A NULL BODY Northwestern Memorial Hosp. NMH5_OC0 NULL NULL NULL 4 467 544 NULL 2003-04-27 22:56:55.000 NULL 2003-04-27 23:14:42.000 8 2009-06-07 09:22:07.640 2015-11-14 03:54:07.407 2015-11-14 03:54:08.290 NULL NULL CT NULL 5706865 5382948 CT 1.2.840.113619.2.55.1.1762864829.1989.1044811980.588.5 5 Recon 2: ROUTINE PE NULL 5.7 ROUTINE PE NULL 1.2.124.113532.10.7.222.5.20030209.190851.3087742.9814.0.12 4 200 NULL NULL NULL 8 NULL NULL NULL 7276786 5706865 3 NULL 4 NULL 0102126763\\1_2_124_113532_10_7_222_5_\\7276786.0 NULL 289158 NULL 3 ASP_NMH_99_LIB2 \\\\asp1nsx02\\ASP_NMH_99_LIB2\\Incoming \\\\asp1nsx02\\ASP_NMH_99_LIB2\\Images LOCAL`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}