#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)(?<blockquote>^> ?.+?)((\r?\n\r?\n\w)|\Z)"
Local $sString = "> ar en resnksndf sdpofmopsdmf" & @CRLF & _
"sdlknksdnkf" & @CRLF & _
"> wofnosidn oi" & @CRLF & _
"> oejfosf" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"> ijewnef" & @CRLF & _
"> kneinfie" & @CRLF & _
"" & @CRLF & _
"reist" & @CRLF & _
"" & @CRLF & _
"> sfosdnf" & @CRLF & _
">wnfoefm"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")