// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)(?<blockquote>^> ?.+?)((\r?\n\r?\n\w)|\Z)").unwrap();
let string = "> ar en resnksndf sdpofmopsdmf
sdlknksdnkf
> wofnosidn oi
> oejfosf
> ijewnef
> kneinfie
reist
> sfosdnf
>wnfoefm";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}