package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^[^@]+@[^@]+\.([^@.]{2,})$`)
var str = `my@email.dot.us
my@email.dot.r`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}