$re = '/^[^@]+@[^@]+\.([^@.]{2,})$/im';
$str = 'my@email.dot.us
my@email.dot.r';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);