#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*\(.+\).*(*SKIP)(*F)|<\?=(.+?)\?>"
Local $sString = "$content = 'Hello world, ( this ) is a string with { curly brackets } and this is for testing'" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" foo(?!\()" & @CRLF & _
"<?= number_format($taghsimatCount) ?>" & @CRLF & _
"ffh<>" & @CRLF & _
"<?= $djhsfgjs ?>" & @CRLF & _
"" & @CRLF & _
"<?= djhsfgjs($fsdjfk) ?>" & @CRLF & _
"" & @CRLF & _
"<?= $fdgdfgfd?>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")