$re = '/^\h*(?=(?:\d+|A)(?:\.\d+)*\.(?!\S))/m';
$str = 'A.8. "text
8.4.2.4.1.2. text
9.1. 12 digit and text
9. text
10.0.1.1. " text
9 text
0.1 Hz
100. text
100.5.1. text
A.500 text
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);