$re = '/<parent>(.|\n)*?<child(a|b)>/mi';
$str = '<Parent>
<ChildA>..</ChildA>
<ChildB>..</ChildB>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);