re = /<parent>(.|\n)*?<child(a|b)>/mi
str = '<Parent>
<ChildA>..</ChildA>
<ChildB>..</ChildB>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end