package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`/^.*((youtu.be\/)|(v\/)|(\/u\/\w\/)|(embed\/)|(watch\?))\??v?=?([^#&?]*).*/`)
var str = `/32`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}