re = /\/^.*((youtu.be\/)|(v\/)|(\/u\/\w\/)|(embed\/)|(watch\?))\??v?=?([^#&?]*).*\//
str = '/32'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end