const regex = /(AND \( wp_term_relationships\.term_taxonomy_id IN \([0-9,]*\) \))/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(AND \\( wp_term_relationships\\.term_taxonomy_id IN \\([0-9,]*\\) \\))', '')
const str = `WHERE 1=1 AND ( wp_term_relationships.term_taxonomy_id IN (800,801) ) AND wp_posts.post_type = 'service_photo' AND (wp_posts.post_status = 'publish' OR wp_posts.post_status = 'private') AND ( wp_postmeta.meta_key = 'custom_meta_partner_subscription_level' )`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);