$re = '/[\w$]+\s*(?=\([^)]*\)\{)/';
$str = 'public int all(){
public long method(int x, String str){';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);