re = /[\w$]+\s*(?=\([^)]*\)\{)/
str = 'public int all(){
public long method(int x, String str){'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end