# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*? (?:VAN|VON|DE)\K |(?<!^)\G\w+\K /-/gim;t' <<< "ANNEKA VANHOVEN BAKKER
HENRIETTA VON DER GRAAF
CAROLINE VAN OOSTEN DE WINKEL
MARC DE VRIES VAN JONG
JOHN SMITH"