$re = '/^\'+\w+/m';
$str = '\'kem
\'kem
dem
elm
i\'am
kem
\'im
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);