package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`-?\d+|[()*/+-]`)
var str = `(1*2)/(3*4)*100+-10
-1*2/3+4--10*-110`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}