$re = '~-?\d+|[()*/+-]~';
$str = '(1*2)/(3*4)*100+-10
-1*2/3+4--10*-110';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);