package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w+ DT)? (\w+ JJ)*|(\w+ (?:NN|NP|PRN))`)
var str = `1/4 cup low fat milk
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}