$re = '/(\w+ DT)? (\w+ JJ)*|(\w+ (?:NN|NP|PRN))/m';
$str = '1/4 cup low fat milk
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);