package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^{24,}*`)
var str = `Winston1-Salem6
Winston-Salem
Winston Salem
1-two3
word2 with space
-Newberty-Los-
12345678901234567890123444
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}