re = /^{24,}*/m
str = 'Winston1-Salem6
Winston-Salem
Winston Salem
1-two3
word2 with space
-Newberty-Los-
12345678901234567890123444
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end