re = /(\W)\1+/m
str = 'dealer said it does not reimburse dealers for loaners or rentals... so why even be a dealership if they make faulty cars and you re on the line to help customers'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result