#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "market\/report\S+(?:\.cpp|\.h)\b"
Local $sString = "test.cpp " & @CRLF & _
"test.h " & @CRLF & _
"test.html " & @CRLF & _
"market/report/test.cpp " & @CRLF & _
"market/report/src/t2.cpp" & @CRLF & _
"not/market/report/a.cpp" & @CRLF & _
"market/library/t.h" & @CRLF & _
"market.cpp"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")