import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "market\\/report\\S+(?:\\.cpp|\\.h)\\b";
final String string = "test.cpp \n"
+ "test.h \n"
+ "test.html \n"
+ "market/report/test.cpp \n"
+ "market/report/src/t2.cpp\n"
+ "not/market/report/a.cpp\n"
+ "market/library/t.h\n"
+ "market.cpp";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}