package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[~([^\]]+)\]`)
var str = `Completely engineer client-based strategic [~theme 123] areas before cross [~media] technology [this is fine] ok?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}