import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:<(\\w+)[^>]*>(?:[\\w+]+(?:(?!<).*)<\\/\\1>?)[^\\s\\w]?|[A-Za-z',]+)";
final String string = "A word, <a href='#' title=''>words within tags should remain intact</a>, so here's\n"
+ "<b>even more</b> <u>words</u>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}