import re
regex = re.compile(r"(?:<(\w+)[^>]*>(?:[\w+]+(?:(?!<).*)<\/\1>?)[^\s\w]?|[A-Za-z',]+)")
test_str = ("A word, <a href='#' title=''>words within tags should remain intact</a>, so here's\n"
"<b>even more</b> <u>words</u>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")