$re = '/(?:<(\w+)[^>]*>(?:[\w+]+(?:(?!<).*?)<\/\1>?)[^\s\w]?|[^\s]+)/';
$str = 'A word, <a href=\'#\' title=\'\'>words within tags should remain intact</a>, so here\'s
<b>even more</b> <u>words</u> <span><b>ads</b>a</span>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);