re = /(?:<(\w+)[^>]*>(?:[\w+]+(?:(?!<).*?)<\/\1>?)[^\s\w]?|[^\s]+)/
str = 'A word, <a href=\'#\' title=\'\'>words within tags should remain intact</a>, so here\'s
<b>even more</b> <u>words</u> <span><b>ads</b>a</span>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end