re = /\w+|'|\ /
str = 'Nadia\'s iPhone /
/
\\/\\\\/\\///\\\\\\(alert "attack!");'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end