#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^[ABC]{3}-[DEF]{3}-[A-Z0-9]+$"
Local $sString = "AAA-EEE-1ifsdfkwer213" & @CRLF & _
"BB-II-sdfdsf" & @CRLF & _
"CAB-eff-123" & @CRLF & _
"ccb-sss-sdf123" & @CRLF & _
"AAc-DDF-123sdfA" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")