$re = '/^[ABC]{3}-[DEF]{3}-[A-Z0-9]+$/mi';
$str = 'AAA-EEE-1ifsdfkwer213
BB-II-sdfdsf
CAB-eff-123
ccb-sss-sdf123
AAc-DDF-123sdfA
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);