using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\R?\R)\R+";
string substitution = @"$1";
string input = @"line1
line2
line3
line4
line5
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}